summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2015-07-16 11:22:36 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2015-07-16 14:15:19 +1000
commite3c9106090788b336acc6b4e83ad1f9829631aa6 (patch)
tree12a5a8174bcbcf6f5cb63b09fa1fc22e4ede129d /doc/Makefile.am
parent0172bfddbdc0093de3e9173465ef5e25e7c2c187 (diff)
doc: use bootstrap for doxygen styling
Makes the documentation less of an eyesore. Header/footer from: https://github.com/Velron/doxygen-bootstrapped, Apache-licensed Bootstrap style from: https://bootswatch.com/paper/, MIT licensed Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index caeebae5..95a96e45 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -43,7 +43,13 @@ diagram_files = \
$(srcdir)/svg/touchscreen-gestures.svg \
$(srcdir)/svg/twofinger-scrolling.svg
-html/index.html: libinput.doxygen $(header_files) $(diagram_files)
+style_files = \
+ style/header.html \
+ style/footer.html \
+ style/customdoxygen.css \
+ style/bootstrap.css
+
+html/index.html: libinput.doxygen $(header_files) $(diagram_files) $(style_files)
$(AM_V_GEN)(cat $<; \
echo "INPUT = $(header_files)"; \
) | $(DOXYGEN) -
@@ -52,8 +58,11 @@ clean-local:
$(AM_V_at)rm -rf html
doc_src= $(shell find html -type f -printf "html/%P\n" 2>/dev/null)
-EXTRA_DIST += $(builddir)/html/index.html $(doc_src) $(diagram_files) $(header_files)
-
+EXTRA_DIST += $(builddir)/html/index.html \
+ $(doc_src) \
+ $(diagram_files) \
+ $(header_files) \
+ $(style_files)
endif
# make sure doc was built before running dist