summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2016-09-13 16:57:25 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2016-11-02 09:03:48 +1000
commite09705522a69d2de94d147f3482089275a8109df (patch)
tree2f5c8a10216cb2dfa95f0b08bc7b2c088937d74b /configure.ac
parent63990614b055ce9f5935d413ec9d5bf5ee1f7caf (diff)
udev: add the hwdb_parser.py test from systemd
upstream for this file lives in systemd, any changes to the actual parser should flow back there. libinput's matches are fairly simple. We have the various LIBINPUT_MODEL_ tags that just take a "1" and the two attributes that are dimensions. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 47e15944..0ae9b762 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,10 @@ AC_PROG_CC_C99
AC_PROG_CXX # Only used by build C++ test
AC_PROG_GREP
+# Only used for testing the hwdb
+AM_PATH_PYTHON([3.0],, [:])
+AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
+
# Initialize libtool
LT_PREREQ([2.2])
LT_INIT