summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-08-05 11:28:43 +0800
committerPeter Hutterer <peter.hutterer@who-t.net>2015-08-07 11:37:38 +1000
commit74236f1047cd0829ad6c96944045e67df3f1fcdb (patch)
tree22a3d0fbc8224875a9ac89f31d8efce9e6c3bd66 /configure.ac
parent2ee2bebb3423d2beb93607ea3f96fe726d95374c (diff)
configure.ac: add arg --with-libunwind
Add arg --with-libunwind for configure so it's optional to check libunwind, which is helpfull to make deterministic builds. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0d5d486c..885cb394 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,13 +60,22 @@ PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(MTDEV, [mtdev >= 1.1.0])
PKG_CHECK_MODULES(LIBUDEV, [libudev])
PKG_CHECK_MODULES(LIBEVDEV, [libevdev >= 0.4])
-PKG_CHECK_MODULES(LIBUNWIND,
+
+AC_ARG_WITH(libunwind,
+ AS_HELP_STRING([--without-libunwind],[Do not use libunwind]))
+
+AS_IF([test "x$with_libunwind" != "xno"],
+ [PKG_CHECK_MODULES(LIBUNWIND,
[libunwind],
[HAVE_LIBUNWIND=yes],
- [HAVE_LIBUNWIND=no])
-if test "x$HAVE_LIBUNWIND" = "xyes"; then
- AC_DEFINE(HAVE_LIBUNWIND, 1, [Have libunwind support])
-fi
+ [HAVE_LIBUNWIND=no])],
+ [HAVE_LIBUNWIND=no])
+
+AS_IF([test "x$HAVE_LIBUNWIND" = "xyes"],
+ [AC_DEFINE(HAVE_LIBUNWIND, 1, [Have libunwind support])],
+ [AS_IF([test "x$with_libunwind" = "xyes"],
+ [AC_MSG_ERROR([libunwind requested but not found])])])
+
AM_CONDITIONAL(HAVE_LIBUNWIND, [test "x$HAVE_LIBUNWIND" = xyes])
AC_PATH_PROG(ADDR2LINE, [addr2line])
if test "x$ADDR2LINE" != "x"; then