summaryrefslogtreecommitdiff
path: root/configure.ac
AgeCommit message (Collapse)AuthorFilesLines
2013-10-08trivial: post release version bumpMartin Pitt1-1/+1
2013-07-26trivial: post release version bumpRichard Hughes1-1/+1
2013-07-26Released UPower 0.9.21UPOWER_0_9_21Richard Hughes1-1/+1
2013-05-07build: detect udev rules dirTom Gundersen1-7/+5
Udev rules may live in either /lib/udev/rules.d or /usr/lib/udev/rules.d depending on the distro. Remove the heuristic for deciding the dir, use pkgconfig to detect the location and allow it to be set manually. v2: fix specifying --with-udevrulesdir Signed-off-by: Richard Hughes <richard@hughsie.com>
2013-05-07Use PIE to better secure installed tools and also use full RELRO in the daemonRichard Hughes1-0/+12
2013-03-21Drop --enable-systemd and linking to libsystemd-daemonMartin Pitt1-32/+0
logind is now being detected at runtime (see previous commit ff39d23), so we do not need to link against libsystemd-daemon any more. Drop --enable-systemd configure option as well.
2013-03-18trivial: post release version bumpRichard Hughes1-1/+1
2013-02-12Add a --enable-deprecated configure argumentRichard Hughes1-0/+10
This is turned off by default. If this is not set, then any calls to Suspend(), SuspendAllowed(), Hibernate() or HibernateAllowed() will fail with an error. The error mesage tells the user what new method to port to in logind. I'm expecting to set --enable-deprecated for Fedora 17 and 18, but turn it off for Fedora 19, so other distributions probably want to follow suit to find out what other stuff needs to be ported to the new APIs early. GNOME should already be fine, but KDE will need some solid porting as I understand it. See http://lists.freedesktop.org/archives/devkit-devel/2013-January/001339.html for more information on future plans and for rationale.
2013-02-12trivial: Remove unused configure argumentsRichard Hughes1-8/+2
2013-02-12Raise the hard PolKit dep to 0.97Richard Hughes1-14/+1
2013-01-09Never use -WError when buildingRichard Hughes1-18/+0
2013-01-02trivial: post release version bumpRichard Hughes1-1/+1
2012-08-08trivial: post release version bumpRichard Hughes1-1/+1
2012-07-11Use systemd for suspend and hibernateMatthias Clasen1-8/+49
When running under systemd, call into systemd for suspend and hibernate instead of pm-utils. To capture resume events, install a small script that gets executed by systemd after resume and sends a dbus signal back to upower. To make this work, the upower backends gain a new signal, ::resuming, that they can optionally emit to signal that a resume happened. Backends opt in to this by returning TRUE from up_backend_emits_resuming(). In this case, upower doesn't assume the sleep command to block until resume, but instead waits for the ::resuming signal from the backend. The only backend that uses this mechanism is the linux backend when built with systemd support. Signed-off-by: Richard Hughes <richard@hughsie.com>
2012-06-25trivial: post release version bumpRichard Hughes1-1/+1
2012-04-30trivial: post release version bumpRichard Hughes1-1/+1
2012-04-30Released UPower 0.9.16UPOWER_0_9_16Richard Hughes1-1/+1
2012-01-17Install a systemd service file if systemd is usedBenedikt Morbach1-0/+8
This makes dbus defer starting upowerd to systemd instead of doing it itself and thus puts the daemon under proper systemd supervision. Signed-off-by: Richard Hughes <richard@hughsie.com>
2011-12-05trivial: post release version bumpRichard Hughes1-1/+1
2011-10-04Add --with-historydir to specify where we want the history files to be storedLandry Breuil1-0/+10
Signed-off-by: Richard Hughes <richard@hughsie.com>
2011-10-03trivial: post release version bumpRichard Hughes1-1/+1
2011-09-08Fix the kFreeBSD detectionPino Toscano1-1/+1
Signed-off-by: Richard Hughes <richard@hughsie.com>
2011-09-05trivial: post release version bumpRichard Hughes1-1/+1
2011-09-02trivial: fix up a trivial typo in the last commitRichard Hughes1-1/+1
Thanks to Emilio López for spotting it!
2011-09-01build: don't rely on files' presence to define the default backend.Diego Elio Pettenò1-9/+6
Files might not be there, or in the case of cross-compilation, they most definitely won't be there (and if they are, they are not the ones you should be looking for). Instead use the autoconf-defined $host variable to identify for what system we're building for. Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu> Signed-off-by: Richard Hughes <richard@hughsie.com>
2011-07-19Use upstream gettext instead the glib oneJavier Jardón1-4/+8
2011-07-19configure.ac: Modernize autotools configJavier Jardón1-23/+19
Require automake 1.11 as Its needed to generate xz tarballs Remove unneded macros
2011-07-04trivial: post release version bumpRichard Hughes1-1/+1
2011-07-04Switch to using .xz tarballsRichard Hughes1-1/+1
2011-05-31Add AC_PROG_LIBTOOL as advised by autotoolsLandry Breuil1-0/+1
2011-05-25trivial: post release version bumpRichard Hughes1-1/+1
2011-05-03trivial: post release version bumpRichard Hughes1-1/+1
2011-03-21-Wuninitialized needs -OLandry Breuil1-1/+1
Signed-off-by: Richard Hughes <richard@hughsie.com>
2011-03-21Add openbsd backend switchesLandry Breuil1-1/+5
Signed-off-by: Richard Hughes <richard@hughsie.com>
2011-03-21trivial: post release version bumpRichard Hughes1-1/+1
2011-03-09Depend on stable GUdev APIMichael Biebl1-1/+1
The GUdev API was declared stable in udev release 147. Bump the version in the configure check and drop the G_UDEV_API_IS_SUBJECT_TO_CHANGE defines. Signed-off-by: Richard Hughes <richard@hughsie.com>
2011-01-07trivial: post release version bumpRichard Hughes1-2/+2
2010-11-04Drop check for polkit-backend againMartin Pitt1-1/+0
This was introduced in 0660e5d2, but we don't use polkit-backend anywhere.
2010-11-04Check for and link against libplistMartin Pitt1-1/+1
src/linux/up-device-idevice.c explicitly uses libplist, so check for it in configure.ac. With gcc 4.5 private requirements of libraries aren't transitively linked any more, thus the build fails with CCLD upowerd /usr/bin/ld.bfd.real: linux/.libs/libupshared.a(libupshared_la-up-device-idevice.o): undefined reference to symbol 'plist_dict_get_item' /usr/bin/ld.bfd.real: note: 'plist_dict_get_item' is defined in DSO /usr/lib64/libplist.so.1 so try adding it to the linker command line /usr/lib64/libplist.so.1: could not read symbols: Invalid operation
2010-11-04Re-add AM_MAINTAINER_MODE (but enable it by default)Michael Biebl1-0/+1
Using AM_MAINTAINER_MODE allows to modify the build systemd without triggering the autotools. We enable it by default so the current behaviour does not change. Signed-off-by: Richard Hughes <richard@hughsie.com>
2010-11-01trivial: post release version bumpRichard Hughes1-2/+2
2010-10-12Do not dist the UPowerGlib-1.0.gir file to fix building on F14Richard Hughes1-1/+1
2010-10-04trivial: post release version bumpRichard Hughes1-1/+1
2010-09-20Allow explicitly disabling libimobiledevice supportBrett Witherspoon1-7/+10
Signed-off-by: Richard Hughes <richard@hughsie.com>
2010-08-31Remove devkit-power-gobjectRichard Hughes1-3/+0
2010-08-10Fix compile with the latest PolicyKit releaseRichard Hughes1-3/+14
2010-07-12trivial: post release version bumpRichard Hughes1-1/+1
2010-06-05Port to GTestRichard Hughes1-4/+1
2010-05-28Add battery query support for iDevicesBastien Nocera1-0/+8
https://bugs.freedesktop.org/show_bug.cgi?id=28286 Signed-off-by: Richard Hughes <richard@hughsie.com>
2010-05-19Remove the artifically high autoconf build requirementRichard Hughes1-1/+1