summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2008-08-01 17:27:12 +0100
committerRichard Hughes <richard@hughsie.com>2008-08-01 17:27:12 +0100
commit74683e3fa712d7f4f2b2474cc4c045020ad2bafb (patch)
tree2ab261d5b30e8ac8e0c9ae899221c7f0e66e85c7 /tools/Makefile.am
parentd06a9707c5e2ab366325e5e8e77207dcc1885c56 (diff)
of course, the right thing to do is make a static lib to avoid playing with ../src/ type paths
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index ef483bc..0f8143f 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -10,10 +10,13 @@ INCLUDES = \
-DPACKAGE_LOCALE_DIR=\""$(localedir)"\" \
-DPACKAGE_LIB_DIR=\""$(libdir)"\" \
-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT \
+ -I$(top_srcdir)/libdevkit-power \
$(DBUS_GLIB_CFLAGS) \
$(POLKIT_DBUS_CFLAGS) \
$(GLIB_CFLAGS)
+DEVKIT_POWER_LIBS = $(top_builddir)/libdevkit-power/libdevkit-power.la
+
BUILT_SOURCES = \
dkp-daemon-glue.h \
dkp-marshal.h dkp-marshal.c
@@ -31,9 +34,6 @@ bin_PROGRAMS = devkit-power
devkit_power_SOURCES = \
dkp-tool.c \
- ../src/dkp-debug.h ../src/dkp-debug.c \
- ../src/dkp-object.h ../src/dkp-object.c \
- ../src/dkp-enum.h ../src/dkp-enum.c \
$(BUILT_SOURCES)
@@ -44,6 +44,7 @@ devkit_power_CPPFLAGS = \
devkit_power_LDADD = \
$(DBUS_GLIB_LIBS) \
+ $(DEVKIT_POWER_LIBS) \
$(POLKIT_DBUS_LIBS)
CLEANFILES = $(BUILT_SOURCES)