summaryrefslogtreecommitdiff
path: root/src/linux/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2009-07-27 16:40:11 +0100
committerRichard Hughes <richard@hughsie.com>2009-07-27 16:40:11 +0100
commit0c8d29a90f5b5b7d84ec834213ac7e4390e89db9 (patch)
tree913239be76d6075d7926c8cd1252060ca9dc170f /src/linux/Makefile.am
parent8cf5c058c337a114d6fc5cf18593c5ecf1099efd (diff)
Initial split to make DeviceKit-power compile without GUdev for non-linux platforms
Diffstat (limited to 'src/linux/Makefile.am')
-rw-r--r--src/linux/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/linux/Makefile.am b/src/linux/Makefile.am
new file mode 100644
index 0000000..489563b
--- /dev/null
+++ b/src/linux/Makefile.am
@@ -0,0 +1,37 @@
+## Process this file with automake to produce Makefile.in
+
+INCLUDES = \
+ -I$(top_builddir)/src -I$(top_srcdir)/src \
+ -DEGG_LOG_FILE=\""$(DKP_LOG_DIR)/DeviceKit-power"\" \
+ -DEGG_VERBOSE="\"DKP_VERBOSE\"" \
+ -DEGG_LOGGING="\"DKP_LOGGING\"" \
+ -DEGG_CONSOLE="\"DKP_CONSOLE\"" \
+ -DDKP_COMPILATION \
+ -I$(top_srcdir)/devkit-power-gobject \
+ $(GIO_CFLAGS) \
+ $(DBUS_GLIB_CFLAGS) \
+ $(GUDEV_CFLAGS) \
+ $(POLKIT_CFLAGS) \
+ $(GLIB_CFLAGS)
+
+noinst_LIBRARIES = libdkpshared.a
+libdkpshared_a_SOURCES = \
+ dkp-device-supply.c \
+ dkp-device-supply.h \
+ dkp-device-csr.c \
+ dkp-device-csr.h \
+ dkp-device-hid.c \
+ dkp-device-hid.h \
+ dkp-device-wup.c \
+ dkp-device-wup.h \
+ dkp-input.c \
+ dkp-input.h \
+ dkp-backend.c \
+ dkp-native.c \
+ sysfs-utils.c \
+ sysfs-utils.h \
+ $(BUILT_SOURCES)
+
+clean-local :
+ rm -f *~
+