summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2010-03-26 07:50:11 +0100
committerMartin Pitt <martin.pitt@ubuntu.com>2010-03-26 11:17:55 +0100
commitf435bf07ac872c4c9675ef11d26a4a355d30610b (patch)
tree9bcd247df513c4b968eaa85ac22d69d1ba606a7c /configure.ac
parent37a56ea0da2e53be880ea5216e5be41b16dc1880 (diff)
Simplify udev subdirectory handling
Use the BACKEND_TYPE_LINUX automake conditional to include the rules directory. This way we don't need to specify DIST_SUBDIRS and can get rid of UDEV_RULES. Less redundandcy, less chance to miss a directory in the dist tarball. Signed-off-by: Martin Pitt <martin.pitt@ubuntu.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 95f288d..e0c214e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,7 +164,6 @@ dnl ---------------------------------------------------------------------------
AC_ARG_WITH([backend],
AS_HELP_STRING([--with-backend=<option>],
[Default backend to use linux, freebsd, dummy (dummy)]))
-UDEV_RULES=
# default to a sane option
if test x$with_backend = x; then
if test -e /usr/include/gudev-1.0/gudev/gudev.h ; then
@@ -187,9 +186,7 @@ if test x$with_backend = xlinux; then
dnl Check libusb also
AC_CHECK_HEADERS(usb.h, , [AC_MSG_ERROR([Can't find usb.h. Please install libusb.])])
AC_CHECK_LIB([usb], [usb_find_devices], [], [AC_MSG_ERROR([Can't use libusb.])])
- UDEV_RULES="rules"
fi
-AC_SUBST(UDEV_RULES)
# export to Makefile.am
AM_CONDITIONAL(BACKEND_TYPE_DUMMY, [test x$with_backend = xdummy])