summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2010-06-05 17:00:34 +0100
committerRichard Hughes <richard@hughsie.com>2010-06-05 17:00:34 +0100
commit6ba86292e9e86601365c23a8f7f89f05a43ccd33 (patch)
tree5d5e16e197415a043ad21f6c98eafc84ea52aa5b /configure.ac
parent82a6a882d03c145625edbe23dade65bc14f85e73 (diff)
Port to GTest
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index bc9baf1..3c79a48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,10 +200,7 @@ dnl - Build self tests
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(tests, AS_HELP_STRING([--enable-tests],[enable unit test code]),
enable_tests=$enableval,enable_tests=yes)
-AM_CONDITIONAL(EGG_BUILD_TESTS, test x$enable_tests = xyes)
-if test x$enable_tests = xyes; then
- AC_DEFINE(EGG_BUILD_TESTS,1,[Build test code])
-fi
+AM_CONDITIONAL(UP_BUILD_TESTS, test x$enable_tests = xyes)
if test "x$GCC" = "xyes"; then
LDFLAGS="-Wl,--as-needed $LDFLAGS"