summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martinpitt@gnome.org>2013-03-21 07:16:56 +0100
committerMartin Pitt <martinpitt@gnome.org>2013-03-21 07:16:56 +0100
commit1540b08f9c18a395e6b84b6f347f998c16f9fb03 (patch)
tree68aa3d247b31854b5f0b707a14e4a41297ed56bc /configure.ac
parentff39d23ff4dc5735dedcb7d0942bd1ebfec0afb7 (diff)
Drop --enable-systemd and linking to libsystemd-daemon
logind is now being detected at runtime (see previous commit ff39d23), so we do not need to link against libsystemd-daemon any more. Drop --enable-systemd configure option as well.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 56db585..51dc080 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,38 +151,6 @@ PKG_CHECK_MODULES(GIO, [gio-2.0 >= 2.16.1])
dnl ====================================================================
dnl Check for systemd
dnl ====================================================================
-AC_ARG_ENABLE([systemd],
- AS_HELP_STRING([--enable-systemd], [Use systemd]),
- [enable_systemd=$enableval],
- [enable_systemd=auto])
-
-PKG_CHECK_MODULES(SYSTEMD,
- [libsystemd-daemon],
- [have_systemd=yes], [have_systemd=no])
-
-AC_MSG_CHECKING([whether to use systemd])
-
-if test x$enable_systemd = xauto ; then
- if test x$have_systemd = xno ; then
- enable_systemd=no
- else
- enable_systemd=yes
- fi
-fi
-AC_MSG_RESULT($enable_systemd)
-
-if test x$enable_systemd = xyes; then
- if test x$have_systemd = xno; then
- AC_MSG_ERROR([Systemd support explicitly required, but systemd not found])
- fi
- AC_DEFINE(HAVE_SYSTEMD, 1, [Define if systemd is used for session tracking])
-fi
-
-AC_SUBST(SYSTEMD_CFLAGS)
-AC_SUBST(SYSTEMD_LIBS)
-
-AM_CONDITIONAL(HAVE_SYSTEMD, [test "$with_systemd" = "yes"], [Using systemd])
-
AC_ARG_WITH([systemdutildir],
AS_HELP_STRING([--with-systemdutildir=DIR], [Directory for systemd utilities]),
[],