summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2010-11-04 18:55:55 -0400
committerMartin Pitt <martin.pitt@ubuntu.com>2010-11-04 18:55:55 -0400
commitd1e6e48ad335c471305f7195f1acba275d114696 (patch)
tree90c74906b9fc382b34078f14efbe6932dd35069b /configure.ac
parent04dd349103ac1db8660d5c4fd86e91e3b488650c (diff)
Check for and link against libplist
src/linux/up-device-idevice.c explicitly uses libplist, so check for it in configure.ac. With gcc 4.5 private requirements of libraries aren't transitively linked any more, thus the build fails with CCLD upowerd /usr/bin/ld.bfd.real: linux/.libs/libupshared.a(libupshared_la-up-device-idevice.o): undefined reference to symbol 'plist_dict_get_item' /usr/bin/ld.bfd.real: note: 'plist_dict_get_item' is defined in DSO /usr/lib64/libplist.so.1 so try adding it to the linker command line /usr/lib64/libplist.so.1: could not read symbols: Invalid operation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 581aa7e..d3aabbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,7 +197,7 @@ if test x$with_backend = xlinux; then
AC_ARG_WITH(idevice, AS_HELP_STRING([--without-idevice],[Build without libimobiledevice]),
with_idevice=$withval,with_idevice=yes)
AS_IF([test "x$with_idevice" != "xno"],
- [PKG_CHECK_MODULES(IDEVICE, libimobiledevice-1.0 >= 0.9.7, have_idevice=yes, have_idevice=no)],
+ [PKG_CHECK_MODULES(IDEVICE, libimobiledevice-1.0 >= 0.9.7 libplist >= 0.12, have_idevice=yes, have_idevice=no)],
[have_idevice=no])
AS_IF([test "x$have_idevice" = "xyes"],
[AC_DEFINE(HAVE_IDEVICE, 1, [Define to 1 if AFC is going to be built])])