summaryrefslogtreecommitdiff
path: root/TelepathyQt4Yell/CMakeLists.txt
diff options
context:
space:
mode:
authorMateu Batle <mateu.batle@collabora.co.uk>2011-01-28 19:00:32 -0500
committerMateu Batle <mateu.batle@collabora.co.uk>2011-02-11 16:51:36 -0500
commit8dfb19dd504bc8f81e53c41deaa7bdce7e40af01 (patch)
tree66c9267eeb9985801e3d8a0ebf2469f805c3626c /TelepathyQt4Yell/CMakeLists.txt
parentdccf51b04c3ee9c9c0d232b272c027714302b328 (diff)
Added cmakefiles for Telepathy Qt4 Yell Farsight
Diffstat (limited to 'TelepathyQt4Yell/CMakeLists.txt')
-rw-r--r--TelepathyQt4Yell/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/TelepathyQt4Yell/CMakeLists.txt b/TelepathyQt4Yell/CMakeLists.txt
index c40c859..7b0fa34 100644
--- a/TelepathyQt4Yell/CMakeLists.txt
+++ b/TelepathyQt4Yell/CMakeLists.txt
@@ -147,3 +147,12 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/TelepathyQt4Yell-uninstalled.pc.in ${
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/TelepathyQt4Yell.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig COMPONENT headers)
add_subdirectory(Models)
+
+# If Farsight was found, install its pkg-config files as well, and go into the subdirectory
+if(FARSIGHT_COMPONENTS_FOUND)
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/TelepathyQt4YellFarsight.pc.in ${CMAKE_CURRENT_BINARY_DIR}/TelepathyQt4YellFarsight.pc)
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/TelepathyQt4YellFarsight-uninstalled.pc.in ${CMAKE_CURRENT_BINARY_DIR}/TelepathyQt4YellFarsight-uninstalled.pc)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/TelepathyQt4YellFarsight.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig COMPONENT farsight_headers)
+endif(FARSIGHT_COMPONENTS_FOUND)
+
+add_subdirectory(Farsight)