summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>2011-01-31 13:36:37 -0200
committerAndre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>2011-01-31 13:36:37 -0200
commit23225baa9b76fa9d678c95c35fda1f3ad50d499f (patch)
tree9dbed23834f95a31db0d6c6bbddb0c672f463403 /CMakeLists.txt
parent83862f5d56ee655d1c797fcbf9c1312704261d51 (diff)
Link development builds with -Wl,--no-add-needed
This increases forwards compatibility with distros using gold as the linker or otherwise using --no-add-needed/--no-copy-dt-needed-entries.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8daa3b4..c90a9ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -143,6 +143,7 @@ macro_log_feature(QT4_GLIB_SUPPORT "Qt4 Glib Support"
find_package(GLIB2)
find_package(GObject)
find_package(DBus)
+find_package(DBusGLib)
# Find telepathy-glib
set(TELEPATHY_GLIB_MIN_VERSION 0.13.0)