summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 5c99ae79b..3e3dae900 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -12,7 +12,11 @@ html_DATA = \
EXTRA_DIST = \
$(man_MANS:.8=.8.in) \
- $(html_DATA:.html=.xml)
+ $(html_DATA:.html=.xml) \
+ xep.dtd \
+ xep.ent \
+ xep.xsd \
+ xep.xsl
CLEANFILES = \
$(man_MANS) \
@@ -21,9 +25,18 @@ CLEANFILES = \
%.8: %.8.in Makefile
$(AM_V_GEN)sed -e 's,[@]libexecdir[@],@libexecdir@,' < $< > $@
-$(html_DATA): %.html: %.xml $(tools_dir)/xep.xsl
- $(AM_V_GEN)$(XSLTPROC) $(tools_dir)/xep.xsl $< > $@
+$(html_DATA): %.html: %.xml xep.xsl xep.dtd xep.ent
+ $(AM_V_GEN)$(XSLTPROC) $(srcdir)/xep.xsl $< > $@
proto-xep-upload: $(html_DATA)
rsync -P $(html_DATA) people.collabora.co.uk:public_html/
.PHONY: proto-xep-upload
+
+maintainer-update-from-xmpp.org:
+ set -e; \
+ for x in xep.dtd xep.ent xep.xsd xep.xsl; do \
+ uri=svn://svn.xmpp.org:7938/xmpp/trunk/extensions/$$x; \
+ svn info $$uri; \
+ svn cat $$uri > $$x.tmp; \
+ mv $$x.tmp $$x; \
+ done