summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2013-09-11 18:46:42 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-09-12 11:25:23 +0100
commita045e770b0409089a8b11dcf81b53ee84a5bd93b (patch)
treec6d79387fa755890ea41f29a51cd1ac3693f9919 /configure.ac
parent5fea368bffc42db3fbaaca4b48f86dd937aff239 (diff)
Require tp-glib 0.21.1 and disable 0.22-deprecated functionality
This might regress if we deprecate more in later telepathy-glib 0.21.x versions, but still seems worth doing. Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Reviewed-by: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=69194
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 501041574..42e33c4c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -297,9 +297,9 @@ AC_SUBST(DBUS_LIBS)
AC_DEFINE(TP_SEAL_ENABLE, [], [Prevent to use sealed variables])
AC_DEFINE(TP_DISABLE_SINGLE_INCLUDE, [], [Disable single header include])
-AC_DEFINE(TP_VERSION_MIN_REQUIRED, TP_VERSION_0_18, [Ignore post 0.18 deprecations])
-AC_DEFINE(TP_VERSION_MAX_ALLOWED, TP_VERSION_0_20, [Prevent post 0.20 APIs])
-PKG_CHECK_MODULES(TP_GLIB, [telepathy-glib >= 0.19.9])
+AC_DEFINE([TP_VERSION_MIN_REQUIRED], [TP_VERSION_0_22], [Ignore post 0.22 deprecations])
+AC_DEFINE([TP_VERSION_MAX_ALLOWED], [TP_VERSION_0_22], [Prevent post 0.22 APIs])
+PKG_CHECK_MODULES(TP_GLIB, [telepathy-glib >= 0.21.1])
AC_SUBST(TP_GLIB_CFLAGS)
AC_SUBST(TP_GLIB_LIBS)