summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-03-09 13:38:04 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-03-23 14:11:48 +0000
commit352d2da805561ec0164a6e800cd3c3e3bbc629f3 (patch)
treeac54d59da94d4397d9c71d3d585d7ac91eb0cbcd /configure.ac
parentf06469da5cfc7c8dc750bce82099dde4b528a20b (diff)
Replace plugindir with an AC_ARG_VAR so it can be passed to configure
This lets you configure the plugin directory: ./configure pluginexecdir='${libdir}/my-gabble-plugins' The directory-name variable has 'exec' in it because Automake installs unknown directory names with 'exec' in their variable name during "make install-exec", and other unknown directory names during "make install-data". Bug: https://bugs.freedesktop.org/show_bug.cgi?id=46417 Reviewed-by: Jonny Lamb <jonny.lamb@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08922eda8..376e979dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,6 +246,11 @@ if test "x$pluginexeclibdir" = x; then
pluginexeclibdir='${libdir}/telepathy/gabble-0/lib'
fi
AC_ARG_VAR([pluginexeclibdir])
+# The actual plugins
+if test "x$pluginexecdir" = x; then
+ pluginexecdir='${libdir}/telepathy/gabble-0/plugins'
+fi
+AC_ARG_VAR([pluginexecdir])
AC_ARG_ENABLE(plugins,
AC_HELP_STRING([--disable-plugins],