summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-02-21 10:18:53 +0100
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-02-21 10:23:20 +0100
commit205df6480b16d66cf74144b37b197251678a565d (patch)
tree7e5bf4d6c4b8cadc789136af068ea2c753f9e49c /configure.ac
parent3d6ba70935c402e1e2b39716ca6014c22aa1520e (diff)
parentb40042c598476bc14f578b1d121c14eb9da59c3e (diff)
Merge branch 'call1' into master+call1
I added the dependency on tp-glib 0.17.5 as it's required for Call1. Conflicts: src/Makefile.am
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 2 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 74d62e395..a7e0c20b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,7 +282,7 @@ PKG_CHECK_MODULES(DBUS, [dbus-1 >= 1.1.0, dbus-glib-1 >= 0.82])
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
-PKG_CHECK_MODULES(TP_GLIB, [telepathy-glib >= 0.17.2])
+PKG_CHECK_MODULES(TP_GLIB, [telepathy-glib >= 0.17.5])
AC_SUBST(TP_GLIB_CFLAGS)
AC_SUBST(TP_GLIB_LIBS)
@@ -313,8 +313,6 @@ AM_CONDITIONAL([WANT_TWISTED_TESTS], test false != "$TEST_PYTHON")
# separate Wocky installation won't clash with them. This is a bit of a hack.
# AX_CONFIG_DIR doesn't make it very easy to pass extra arguments to the
# submodule's configure.
-#
-# Also do this for telepathy-yell.
prev_ac_configure_args=$ac_configure_args
ac_configure_args="$ac_configure_args --with-installed-headers=${wocky_install_headers_dir}"
@@ -344,16 +342,11 @@ prev_top_build_prefix=$ac_top_build_prefix
AX_CONFIG_DIR([lib/ext/wocky])
ac_top_build_prefix=$prev_top_build_prefix
-dnl tp-yell
-prev_top_build_prefix=$ac_top_build_prefix
-AX_CONFIG_DIR([lib/ext/telepathy-yell])
-ac_top_build_prefix=$prev_top_build_prefix
-
ac_configure_args=$prev_ac_configure_args
dnl Check if Android build
AC_ARG_ENABLE(submodules,
- AS_HELP_STRING([--disable-submodules],[Use system versions of Wocky and Telepathy-Yell, rather than submodules]),
+ AS_HELP_STRING([--disable-submodules],[Use system versions of Wocky, rather than submodules]),
build_submodules=$enableval, build_submodules=yes )
dnl Check for Wocky
@@ -366,14 +359,6 @@ PKG_CHECK_MODULES(WOCKY, wocky >= 0.0.0)
AC_SUBST(WOCKY_CFLAGS)
AC_SUBST(WOCKY_LIBS)
-dnl Check for tp-yell
-if test x$build_submodules = xyes; then
- export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:"$ac_top_build_prefix"lib/ext/telepathy-yell/telepathy-yell
-fi
-PKG_CHECK_MODULES(TP_YELL, telepathy-yell)
-AC_SUBST(TP_YELL_CFLAGS)
-AC_SUBST(TP_YELL_LIBS)
-
AC_ARG_ENABLE(google-relay,
AC_HELP_STRING([--disable-google-relay],
[disable Google Jingle relay support]),