summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@googlemail.com>2015-06-14 13:09:06 +0200
committerDavid Herrmann <dh.herrmann@googlemail.com>2015-06-14 13:09:06 +0200
commitf3a8f45b2128d0b396f000e8a55943857884ac29 (patch)
tree3441a8ddfc55462489362c1ea7b1ace7b4363a38 /Makefile.am
parent6113cec066cd673a60e3bb32b9bd1280e86b2490 (diff)
parentb3d5018b022e3bab06fa30fd8ad73086172670b4 (diff)
Merge pull request #191 from kaysievers/resolv
build-sys: merge convenience library libresolve
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 7 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index de42a2ffb..5b519482f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2913,24 +2913,19 @@ libsystemd_internal_la_SOURCES = \
src/libsystemd/sd-device/device-enumerator-private.h \
src/libsystemd/sd-device/sd-device.c \
src/libsystemd/sd-device/device-private.c \
- src/libsystemd/sd-device/device-private.h
+ src/libsystemd/sd-device/device-private.h \
+ src/libsystemd/sd-resolve/sd-resolve.c \
+ src/libsystemd/sd-resolve/resolve-util.h
nodist_libsystemd_internal_la_SOURCES = \
src/libsystemd/libsystemd.sym
libsystemd_internal_la_LIBADD = \
- libbasic.la
-
-libsystemd_resolve_la_SOURCES = \
- src/libsystemd/sd-resolve/sd-resolve.c \
- src/libsystemd/sd-resolve/resolve-util.h
-
-libsystemd_resolve_la_LIBADD = \
+ libbasic.la \
-lresolv
noinst_LTLIBRARIES += \
- libsystemd-internal.la \
- libsystemd-resolve.la
+ libsystemd-internal.la
EXTRA_DIST += \
src/libsystemd/libsystemd.sym.m4 \
@@ -2943,7 +2938,6 @@ BUILT_SOURCES += \
libsystemd_la_SOURCES = \
$(libsystemd_internal_la_SOURCES) \
- $(libsystemd_resolve_la_SOURCES) \
$(libsystemd_journal_internal_la_SOURCES)
nodist_libsystemd_la_SOURCES = \
@@ -2951,7 +2945,6 @@ nodist_libsystemd_la_SOURCES = \
libsystemd_la_CFLAGS = \
$(libsystemd_internal_la_CFLAGS) \
- $(libsystemd_resolve_la_CFLAGS) \
$(libsystemd_journal_internal_la_CFLAGS)
libsystemd_la_LDFLAGS = \
@@ -2961,8 +2954,7 @@ libsystemd_la_LDFLAGS = \
libsystemd_la_LIBADD = \
$(libsystemd_internal_la_LIBADD) \
- $(libsystemd_journal_internal_la_LIBADD) \
- $(libsystemd_resolve_la_LIBADD)
+ $(libsystemd_journal_internal_la_LIBADD)
libsystemd-install-hook:
libname=libsystemd.so && $(move-to-rootlibdir)
@@ -3148,7 +3140,6 @@ test_resolve_SOURCES = \
src/libsystemd/sd-resolve/test-resolve.c
test_resolve_LDADD = \
- libsystemd-resolve.la \
libshared.la
busctl_SOURCES = \
@@ -4382,8 +4373,7 @@ systemd_socket_proxyd_SOURCES = \
systemd_socket_proxyd_LDADD = \
libsystemd-journal-internal.la \
- libshared.la \
- libsystemd-resolve.la
+ libshared.la
# ------------------------------------------------------------------------------
if ENABLE_COREDUMP
@@ -4847,7 +4837,6 @@ gperf_gperf_sources += \
src/timesync/timesyncd-gperf.gperf
systemd_timesyncd_LDADD = \
- libsystemd-resolve.la \
libsystemd-network.la \
libshared.la