summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCristian Rodríguez <crrodriguez@opensuse.org>2015-06-15 13:36:51 -0300
committerCristian Rodríguez <crrodriguez@opensuse.org>2015-06-15 13:36:51 -0300
commite1ada21e92f7de972bb328e248dcd67641841c25 (patch)
tree581aeed360d60399444568ed5515acad9467eec7 /Makefile.am
parenta4c8a5995102144225439c0077bbda5325761986 (diff)
buildsys: missing SECCOMP_CFLAGS in various places
libcore, systemd and nspawn fail to build when seccomp headers are not in the include path.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a2e8709e5..c1516db08 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1188,7 +1188,8 @@ libcore_la_CFLAGS = \
$(AUDIT_CFLAGS) \
$(KMOD_CFLAGS) \
$(APPARMOR_CFLAGS) \
- $(MOUNT_CFLAGS)
+ $(MOUNT_CFLAGS) \
+ $(SECCOMP_CFLAGS)
libcore_la_LIBADD = \
libshared.la \
@@ -1316,6 +1317,10 @@ src/resolve/dns_type-from-name.gperf: src/resolve/dns_type-list.txt
systemd_SOURCES = \
src/core/main.c
+systemd_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(SECCOMP_CFLAGS)
+
systemd_LDADD = \
libcore.la
@@ -2737,7 +2742,8 @@ systemd_nspawn_SOURCES = \
systemd_nspawn_CFLAGS = \
$(AM_CFLAGS) \
- $(BLKID_CFLAGS)
+ $(BLKID_CFLAGS) \
+ $(SECCOMP_CFLAGS)
systemd_nspawn_LDADD = \
libshared.la \