summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-13 21:59:11 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-13 22:20:51 -0400
commitd29dd033022b41794c7475a5ec4d9d683d18417e (patch)
tree19200b94caed8c4e503b15715d4f6d7157abd8a4 /Makefile.am
parent1609dcb137813e8215d9ecc1f79c7dd7a788d5e0 (diff)
build-sys: link libsystemd-login also against libsystemd-daemon-internal
https://bugs.freedesktop.org/show_bug.cgi?id=62085 /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libsystemd-login.so: undefined reference to `sd_listen_fds' In ee465038ce8 'build-sys: break dependency loop between libsystemd-id128.la and -shared.la', a partial fix was applied, and the use of functions from libsystemd-id128 was removed from libsystemd-shared. Nevertheless, fdset.c was still using sd_listen_fds, so libsystemd-login should be linked against libysystemd-daemon or libsystemd-daemon-internal. Tested-by: Elias Probst <mail@eliasprobst.eu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a12e57ecd..175d14b3a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3356,7 +3356,8 @@ libsystemd_login_la_LDFLAGS = \
-Wl,--version-script=$(top_srcdir)/src/login/libsystemd-login.sym
libsystemd_login_la_LIBADD = \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ libsystemd-daemon-internal.la
libsystemd_login_internal_la_SOURCES = \
$(libsystemd_login_la_SOURCES)