summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-11-23 14:23:54 +0100
committerHans de Goede <hdegoede@redhat.com>2011-11-25 18:22:53 +0100
commit2bcb9fc8cace35cb82226109192e40cf34369a0c (patch)
treed702451e55f03da66cdd8ea2325ecc9eb4781747 /configure.ac
parentd25ff6c56673ca572d0b8fdbaf9d55534889689e (diff)
Switch to autotools build system
Replace the current build system with an autotools based one. HdG, 3 small changes: 1) LIBUSBREDIRPARSER_SO_VERSION 1:0:0 should be 0:0:0, so that the soname does not change by going from Makefiles to autofoo 2) Drop LIBGPOD_SO_VERSION from configure.ac 3) Make libusb pkgconfig check require version >= 1.0.9 Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 41 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..1569453
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,41 @@
+AC_PREREQ(2.63)
+AC_INIT([usbredir], [0.3.1])
+AC_CONFIG_SRCDIR([configure.ac])
+
+AM_CONFIG_HEADER([config.h])
+
+dnl libtool versioning
+# +1 : 0 : +1 == adds new functions to the interface
+# +1 : 0 : 0 == changes or removes functions (changes include both
+# changes to the signature and the semantic)
+# ? :+1 : ? == just internal changes
+# CURRENT : REVISION : AGE
+LIBUSBREDIRHOST_SO_VERSION=1:0:0
+AC_SUBST(LIBUSBREDIRHOST_SO_VERSION)
+
+LIBUSBREDIRPARSER_SO_VERSION=0:0:0
+AC_SUBST(LIBUSBREDIRPARSER_SO_VERSION)
+
+AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip])
+m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+
+AC_PROG_CC
+AC_HEADER_STDC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+LT_INIT
+dnl AC_DEFINE(_GNU_SOURCE, [1], [Enable GNU extensions])
+
+PKG_PROG_PKG_CONFIG
+PKG_CHECK_MODULES(LIBUSB, [libusb-1.0 >= 1.0.9])
+
+AC_CONFIG_FILES([
+Makefile
+usbredirhost/Makefile
+usbredirhost/libusbredirhost.pc
+usbredirparser/Makefile
+usbredirparser/libusbredirparser.pc
+usbredirserver/Makefile
+usbredirtestclient/Makefile
+])
+AC_OUTPUT