summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2021-02-11 08:56:22 +0300
committerIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2021-02-12 20:34:11 +0300
commitde8b7c0d8f3e486f1c853fe5049124ae0416dc4d (patch)
tree1fec2199f4617933563762dbdc26cb444a490713 /meson.build
parent156e16f941789c5d53cdb0c46be480c64e3149f1 (diff)
build-sys: meson: support elogind alternative for module-systemd-login
Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/502>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7da784cc8..5a1df59d9 100644
--- a/meson.build
+++ b/meson.build
@@ -655,6 +655,11 @@ if systemd_dep.found() and systemduserunitdir == ''
systemduserunitdir = systemd_dep.get_pkgconfig_variable('systemduserunitdir')
endif
+libelogind_dep = dependency('libelogind', required : get_option('elogind'))
+if libelogind_dep.found()
+ cdata.set('HAVE_SYSTEMD_LOGIN', 1)
+endif
+
tcpwrap_dep = cc.find_library('wrap', required: get_option('tcpwrap'))
if cc.has_header('tcpd.h') and cc.has_function('hosts_access', dependencies : tcpwrap_dep)
cdata.set('HAVE_LIBWRAP', 1)
@@ -899,6 +904,7 @@ summary = [
'Enable udev: @0@'.format(udev_dep.found()),
' Enable HAL->udev compat: @0@'.format(get_option('hal-compat')),
'Enable systemd: @0@'.format(libsystemd_dep.found()),
+ 'Enable elogind: @0@'.format(libelogind_dep.found()),
'Enable TCP Wrappers: @0@'.format(tcpwrap_dep.found()),
'Enable libsamplerate: @0@'.format(samplerate_dep.found()),
'Enable IPv6: @0@'.format(get_option('ipv6')),