summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 614fe38d..df1809a2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -26,6 +26,12 @@ endif
endif
+if BUILD_SPLASH_OUTPUT
+
+perf_test = \
+ perf-test
+
+endif
INCLUDES = \
-I$(top_srcdir) \
@@ -36,7 +42,7 @@ INCLUDES = \
$(GTK_TEST_CFLAGS) \
$(FONTCONFIG_CFLAGS)
-noinst_PROGRAMS = $(gtk_splash_test) $(gtk_cairo_test) $(pdf_inspector)
+noinst_PROGRAMS = $(gtk_splash_test) $(gtk_cairo_test) $(pdf_inspector) $(perf_test)
gtk_splash_test_SOURCES = \
gtk-splash-test.cc
@@ -65,5 +71,13 @@ pdf_inspector_LDADD = \
$(FREETYPE_LIBS) \
$(GTK_TEST_LIBS)
+perf_test_SOURCES = \
+ perf-test.cc \
+ perf-test-preview-dummy.cc
+
+perf_test_LDADD = \
+ $(top_builddir)/poppler/libpoppler.la \
+ $(FREETYPE_LIBS)
+
EXTRA_DIST = \
pdf-operators.c