summaryrefslogtreecommitdiff
path: root/poppler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'poppler/Makefile.am')
-rw-r--r--poppler/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/poppler/Makefile.am b/poppler/Makefile.am
index abb0dd24..b54eb139 100644
--- a/poppler/Makefile.am
+++ b/poppler/Makefile.am
@@ -17,10 +17,10 @@ endif
if BUILD_POPPLER_QT4
-arthur_headers = \
- ArthurOutputDev.h
+poppler_arthur = libpoppler-arthur.la
-arthur_sources = \
+libpoppler_arthur_la_SOURCES = \
+ ArthurOutputDev.h \
ArthurOutputDev.cc
arthur_includes = \
@@ -79,13 +79,13 @@ INCLUDES = \
lib_LTLIBRARIES = libpoppler.la
-noinst_LTLIBRARIES = $(poppler_cairo)
+noinst_LTLIBRARIES = $(poppler_cairo) \
+ $(poppler_arthur)
libpoppler_la_LIBADD = \
$(top_builddir)/goo/libgoo.la \
$(top_builddir)/fofi/libfofi.la \
$(splash_libs) \
- $(arthur_libs) \
$(libjpeg_libs) \
$(zlib_libs) \
$(FREETYPE_LIBS)
@@ -97,7 +97,6 @@ if ENABLE_XPDF_HEADERS
poppler_includedir = $(includedir)/poppler
poppler_include_HEADERS = \
$(splash_headers) \
- $(arthur_headers) \
Annot.h \
Array.h \
BaseFile.h \