summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 13 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d57f6d1..43334f69 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,18 @@
if BUILD_SPLASH_OUTPUT
splash_subdir = splash
+splash_pc_file = poppler-splash.pc
+endif
+
+if BUILD_CAIRO_OUTPUT
+cairo_pc_file = poppler-cairo.pc
endif
-SUBDIRS = goo fofi $(splash_subdir) poppler test
+if BUILD_POPPLER_GLIB
+glib_subdir = glib
+glib_pc_file = poppler-glib.pc
+endif
+
+SUBDIRS = goo fofi $(splash_subdir) poppler $(glib_subdir) test
EXTRA_DIST = \
README-XPDF \
@@ -10,20 +20,9 @@ EXTRA_DIST = \
poppler-cairo.pc.in \
poppler-splash.pc.in
-if BUILD_SPLASH_OUTPUT
-
-splash_pc_file = poppler-splash.pc
-
-endif
-
-if BUILD_CAIRO_OUTPUT
-
-cairo_pc_file = poppler-cairo.pc
-
-endif
-
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = \
poppler.pc \
$(cairo_pc_file) \
- $(splash_pc_file)
+ $(splash_pc_file) \
+ $(glib_pc_file)