summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <aacid@kde.org>2010-02-21 16:59:57 +0000
committerAlbert Astals Cid <aacid@kde.org>2010-02-21 16:59:57 +0000
commitfa0989297e95b6adebed71336ea206d1b279ab24 (patch)
tree29f0a52ce94fdaebf1d874d44227fe47c597051e /test/CMakeLists.txt
parentd074485aa9d9fac6b715382002f53e3303bbc519 (diff)
Detect the need for nanosleep in solaris
Fixes bug 26650
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2c6ec36f..eada899d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,12 +1,17 @@
if (ENABLE_SPLASH)
- set (perf_test_SRCS
- perf-test.cc
- perf-test-preview-dummy.cc
- )
- add_executable(perf-test ${perf_test_SRCS})
- target_link_libraries(perf-test poppler)
+ if (HAVE_NANOSLEEP OR LIB_RT_HAS_NANOSLEEP)
+ set (perf_test_SRCS
+ perf-test.cc
+ perf-test-preview-dummy.cc
+ )
+ add_executable(perf-test ${perf_test_SRCS})
+ target_link_libraries(perf-test poppler)
+ if (LIB_RT_HAS_NANOSLEEP)
+ target_link_libraries(perf-test rt)
+ endif (LIB_RT_HAS_NANOSLEEP)
+ endif (HAVE_NANOSLEEP OR LIB_RT_HAS_NANOSLEEP)
endif (ENABLE_SPLASH)