summaryrefslogtreecommitdiff
path: root/poppler/Makefile.am
diff options
context:
space:
mode:
authorAdrian Perez de Castro <aperez@igalia.com>2013-06-17 17:00:27 +0300
committerCarlos Garcia Campos <carlosgc@gnome.org>2013-10-02 12:34:00 +0200
commite04cabd878a0fd84faa5178f423fd828d010b664 (patch)
tree04d6cbd9439d2bbfbc8a7e3ed58b158d5d88dc4b /poppler/Makefile.am
parent45e0fe56985f34e695c99a2f6ec1ffe14e239b9e (diff)
Tagged-PDF: Implement parsing of StructTreeRoot
Implement parsing of the StructTreeRoot entry of the Catalog. Also, the Catalog::getStructTreeRoot() and PDFDoc::getStructTreeRoot() methods are modified to return an instance of StructTreeRoot instead of an Object. All elements from the StructTreeRoot are parsed except for: - IDTree: it is a lookup tree to locate items by their ID, which would be barely useful because the whole structure tree is to be kept in memory, which should be fast enough to traverse. - ParentTreeNextKey: This is needed only when the ParentTree object is to be modified. For the moment the implementation deals only with reading, so this has been deliberately left out. StructElem tree nodes from the document structure tree are parsed as a StructElement instance. Attributes and extraction of content out from elements are not yet handled. https://bugs.freedesktop.org/show_bug.cgi?id=64815
Diffstat (limited to 'poppler/Makefile.am')
-rw-r--r--poppler/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/poppler/Makefile.am b/poppler/Makefile.am
index aa7c9242..9f90c9d2 100644
--- a/poppler/Makefile.am
+++ b/poppler/Makefile.am
@@ -216,6 +216,8 @@ poppler_include_HEADERS = \
StdinPDFDocBuilder.h \
Stream-CCITT.h \
Stream.h \
+ StructElement.h \
+ StructTreeRoot.h \
UnicodeMap.h \
UnicodeMapTables.h \
UnicodeTypeTable.h \
@@ -294,6 +296,8 @@ libpoppler_la_SOURCES = \
StdinCachedFile.cc \
StdinPDFDocBuilder.cc \
Stream.cc \
+ StructTreeRoot.cc \
+ StructElement.cc \
strtok_r.cpp \
UnicodeMap.cc \
UnicodeTypeTable.cc \