summaryrefslogtreecommitdiff
path: root/glib/CMakeLists.txt
diff options
context:
space:
mode:
authorJeroen Ooms <jeroenooms@gmail.com>2018-12-09 17:21:28 +0100
committerAlbert Astals Cid <tsdgeos@yahoo.es>2018-12-24 17:59:44 +0000
commit72c316d12e1fe26bf6b4f3911ba8e5bcc46af354 (patch)
treee2d5abc83a9a9461a0aaba389dd7eb17332916ae /glib/CMakeLists.txt
parent6e7cbc713ae584d195f77845d6cafcdc80fb64ab (diff)
Windows: only set SOVERSION for shared libs
Diffstat (limited to 'glib/CMakeLists.txt')
-rw-r--r--glib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
index ecdd38ca..6958caf6 100644
--- a/glib/CMakeLists.txt
+++ b/glib/CMakeLists.txt
@@ -90,7 +90,7 @@ set_target_properties(poppler-glib PROPERTIES VERSION 8.11.0 SOVERSION 8)
set_target_properties(poppler-glib PROPERTIES C_VISIBILITY_PRESET hidden)
set_target_properties(poppler-glib PROPERTIES CXX_VISIBILITY_PRESET hidden)
set_target_properties(poppler-glib PROPERTIES VISIBILITY_INLINES_HIDDEN 1)
-if(MINGW)
+if(MINGW AND BUILD_SHARED_LIBS)
get_target_property(POPPLER_GLIB_SOVERSION poppler-glib SOVERSION)
set_target_properties(poppler-glib PROPERTIES SUFFIX "-${POPPLER_GLIB_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()