summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2005-04-05 17:46:44 +0000
committerKristian Høgsberg <krh@redhat.com>2005-04-05 17:46:44 +0000
commitd91dd69a7a0dd581c26728d2640e4d36a7ffe75f (patch)
tree38c21a849ef367b4282af348a3f6951e0e6ea021 /configure.ac
parentb62b0cec2335d987b31fbb0043cb33db29cc6a13 (diff)
2005-04-05 Kristian Høgsberg <krh@redhat.com>poppler-0.2.0
* NEWS: Attempt to sum up changes since 0.1.2. * configure.ac: Bump release to 0.2.0, add AC_DEFINEs for cairo and splash availability. * poppler/CairoFontEngine.cc: Disable hinting. * glib/poppler-page.cc (poppler_page_render_to_pixbuf): Choose either splash or cairo rendering, based on configure choice. (cairo_render_to_pixbuf): New function to render using the cairo backend. (splash_render_to_pixbuf): Split out the splash code to this function.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2a1a2bf5..1a90c578 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl Based on Xpdf configure.in and evince configure.ac
AC_PREREQ(2.59)
-AC_INIT(poppler, 0.1.2)
+AC_INIT(poppler, 0.2.0)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AM_CONFIG_HEADER(config.h)
AM_CONFIG_HEADER(poppler/poppler-config.h)
@@ -142,6 +142,10 @@ if test x$enable_splash_output = xyes; then
PKG_CHECK_MODULES(SPLASH, fontconfig)
fi
AM_CONDITIONAL(BUILD_SPLASH_OUTPUT, test x$enable_splash_output = xyes)
+AH_TEMPLATE([HAVE_SPLASH], [Use splash for rendering.])
+if test x$enable_splash_output = xyes; then
+ AC_DEFINE(HAVE_SPLASH)
+fi
AC_ARG_ENABLE(cairo-output,
AC_HELP_STRING([--disable-cairo-output],
@@ -149,14 +153,18 @@ AC_ARG_ENABLE(cairo-output,
enable_cairo_output=$enableval,
enable_cairo_output="try")
if test x$enable_cairo_output = xyes; then
- PKG_CHECK_MODULES(CAIRO, cairo = 0.4)
+ PKG_CHECK_MODULES(CAIRO, cairo = 0.4.0)
elif test x$enable_cairo_output = xtry; then
- PKG_CHECK_MODULES(CAIRO, cairo = 0.4,
+ PKG_CHECK_MODULES(CAIRO, cairo = 0.4.0,
[enable_cairo_output="yes"],
[enable_cairo_output="no"])
fi
-AM_CONDITIONAL(BUILD_CAIRO_OUTPUT, test x$enable_cairo_output = xyes)
+AM_CONDITIONAL(BUILD_CAIRO_OUTPUT, test x$enable_cairo_output = xyes)
+AH_TEMPLATE([HAVE_CAIRO], [Use cairo for rendering.])
+if test x$enable_cairo_output = xyes; then
+ AC_DEFINE(HAVE_CAIRO)
+fi
AC_ARG_ENABLE(poppler-glib,
AC_HELP_STRING([--disable-poppler-glib],