summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2006-04-12 02:07:07 +0000
committerKristian Høgsberg <krh@redhat.com>2006-04-12 02:07:07 +0000
commitd839a0bd78361930e5e2fe889df12e1e853ffed3 (patch)
treee0bb395c98ad609c8f08c112df82700bb124d990 /configure.ac
parentb198c9801c668014c0979c57033a0637e7e046e2 (diff)
2006-04-11 Kristian Høgsberg <krh@redhat.com>
* configure.ac: * poppler-glib.pc.in: * glib/Makefile.am: * glib/poppler-page.cc: * glib/poppler-page.h: * glib/poppler.h: * poppler/CairoOutputDev.cc: * poppler/CairoOutputDev.h: * glib/poppler-features.h.in: Make the CairoOutputDev render to a cairo_t instead of a cairo_surface_t and expose that functionality in the glib wrapper (poppler_page_render). * test/Makefile.am: * test/gtk-cairo-test.cc: Update gtk-cairo-test to use this new interface and add a spin button for changing page (#5951). * utils/Makefile.am (EXTRA_DIST): Fix warning where this was assigned twice.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0686a531..987fc4cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -182,7 +182,14 @@ AM_CONDITIONAL(BUILD_CAIRO_OUTPUT, test x$enable_cairo_output = xyes)
AH_TEMPLATE([HAVE_CAIRO], [Use cairo for rendering.])
if test x$enable_cairo_output = xyes; then
AC_DEFINE(HAVE_CAIRO)
+ CAIRO_FEATURE="#define POPPLER_HAS_CAIRO 1"
+ CAIRO_REQ="cairo"
+else
+ CAIRO_FEATURE="#undef POPPLER_HAS_CAIRO"
+ CAIRO_REQ=""
fi
+AC_SUBST(CAIRO_FEATURE)
+AC_SUBST(CAIRO_REQ)
AC_ARG_ENABLE(poppler-glib,
AC_HELP_STRING([--disable-poppler-glib],
@@ -306,6 +313,7 @@ splash/Makefile
poppler/Makefile
utils/Makefile
glib/Makefile
+glib/poppler-features.h
glib/reference/Makefile
test/Makefile
qt/Makefile