summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrad Hards <bradh@frogmouth.net>2005-06-28 10:00:09 +0000
committerBrad Hards <bradh@frogmouth.net>2005-06-28 10:00:09 +0000
commitea58a20bbcf450a1ecb8fe00e8162cfdf76105f1 (patch)
tree99d7bbf7b0bde37fd723a4b79a1f966572d68e7d /Makefile.am
parent61e9bc76eb2fcb0b4b899ebfad1cc71c59fc8274 (diff)
Initial import of Qt4 bindings, and for a Qt4 "Arthur" (QPainter)
backend renderer. The bindings are currently unstable - you can expect substantial change in both source and binary interfaces. The Arthur renderer currently does a reasonable job of rendering path and fill, but the image rendering doesn't work (for reasons that aren't clear to me) and text rendering doesn't use the right glyphs - it just draws with the current font. There is a lot of work to do on this too. Help is, of coure, welcome.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3653890d..a8d53613 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,12 @@ qt_subdir = qt
qt_pc_file = poppler-qt.pc
endif
-SUBDIRS = goo fofi $(splash_subdir) poppler $(glib_subdir) $(qt_subdir) test
+if BUILD_POPPLER_QT4
+qt4_subdir = qt4
+qt4_pc_file = poppler-qt4.pc
+endif
+
+SUBDIRS = goo fofi $(splash_subdir) poppler $(glib_subdir) $(qt_subdir) test $(qt4_subdir)
EXTRA_DIST = \
README-XPDF \
@@ -32,4 +37,5 @@ pkgconfig_DATA = \
$(cairo_pc_file) \
$(splash_pc_file) \
$(glib_pc_file) \
- $(qt_pc_file)
+ $(qt_pc_file) \
+ $(qt4_pc_file)