summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzdenop <zdenop@gmail.com>2019-04-29 18:06:57 +0200
committerAlbert Astals Cid <tsdgeos@yahoo.es>2019-05-27 13:53:06 +0000
commitc250cbd2ef18aca9748e2e8d753a2cb414f6f1d9 (patch)
tree7f9aa53f6d2db31d055a22a5531f06b22a882ca0 /CMakeLists.txt
parentce8f750d8dcd029dc5a3a60e2ac1d0b16fd27ebf (diff)
install pkg-config pc files if pkg-config is found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt35
1 files changed, 19 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1eb39f36..ae7ff4ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -687,24 +687,27 @@ else()
set(PC_REQUIRES_PRIVATE "")
endif()
-poppler_create_install_pkgconfig(poppler.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-if(ENABLE_SPLASH)
- poppler_create_install_pkgconfig(poppler-splash.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-endif()
-if(ENABLE_QT5)
- poppler_create_install_pkgconfig(poppler-qt5.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-endif()
-if(ENABLE_GLIB)
- poppler_create_install_pkgconfig(poppler-glib.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-endif()
-if(CAIRO_FOUND)
- poppler_create_install_pkgconfig(poppler-cairo.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-endif()
-if(ENABLE_CPP)
- poppler_create_install_pkgconfig(poppler-cpp.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+if(PKG_CONFIG_EXECUTABLE)
+ poppler_create_install_pkgconfig(poppler.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ if(ENABLE_SPLASH)
+ poppler_create_install_pkgconfig(poppler-splash.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
+ if(ENABLE_QT5)
+ poppler_create_install_pkgconfig(poppler-qt5.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
+ if(ENABLE_GLIB)
+ poppler_create_install_pkgconfig(poppler-glib.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
+ if(CAIRO_FOUND)
+ poppler_create_install_pkgconfig(poppler-cairo.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
+ if(ENABLE_CPP)
+ poppler_create_install_pkgconfig(poppler-cpp.pc ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
+else()
+ MESSAGE(STATUS ".pc files will not be installed becasue of missing 'pkg-config'!")
endif()
-
message("Building Poppler with support for:")
show_end_message("font configuration" ${font_configuration})
show_end_message_yesno("splash output" ENABLE_SPLASH)