summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index def6850..925886a 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -26,11 +26,13 @@ MAINTAINERCLEANFILES = \
.xml.8:
$(XMLTO) man $?
-install-data-hook:
- -mkdir -p $(DESTDIR)$(mandir)/man8
- -ln -s pm-action.8 $(DESTDIR)$(mandir)/man8/pm-suspend.8
- -ln -s pm-action.8 $(DESTDIR)$(mandir)/man8/pm-hibernate.8
- -ln -s pm-action.8 $(DESTDIR)$(mandir)/man8/pm-suspend-hybrid.8
+install-data-hook: install-man
+ @if test -f $(DESTDIR)$(mandir)/man8/pm-action.8; then \
+ for page in pm-suspend pm-hibernate pm-suspend-hybrid; do \
+ echo ln -s pm-action.8 $(DESTDIR)$(mandir)/man8/$$page.8; \
+ ln -s pm-action.8 $(DESTDIR)$(mandir)/man8/$$page.8 || exit 1; \
+ done; \
+ fi
clean-local :
rm -f *~