summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/Makefile.am19
-rw-r--r--debian/README6
-rw-r--r--debian/README.Debian6
-rw-r--r--debian/compat1
-rw-r--r--debian/control17
-rw-r--r--debian/copyright40
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs2
-rw-r--r--debian/pm-utils.doc-base.EX22
-rwxr-xr-xdebian/rules10
10 files changed, 125 insertions, 0 deletions
diff --git a/debian/Makefile.am b/debian/Makefile.am
new file mode 100644
index 0000000..090e3b7
--- /dev/null
+++ b/debian/Makefile.am
@@ -0,0 +1,19 @@
+EXTRA_DIST = changelog \
+ compat \
+ control \
+ copyright \
+ dirs \
+ docs \
+ pm-utils.doc-base.EX \
+ README \
+ README.Debian \
+ rules
+
+.PHONY: changelog
+
+changelog: Makefile
+ git --git-dir="$(srcdir)/../.git" log --pretty=format:"pm-utils (%ct.%h) unstable; urgency=low%n%n * %s%n%n -- %an <%ae> %aD%n" --no-merges >$@
+
+dist-hook: changelog
+
+DISTCLEANFILES = changelog
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..8bcc514
--- /dev/null
+++ b/debian/README
@@ -0,0 +1,6 @@
+The Debian Package pm-utils
+----------------------------
+
+Comments regarding the Package
+
+ -- Victor Lowther <victor.lowther@gmail.com> Wed, 05 Mar 2008 23:51:41 -0600
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..7e0fdf8
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,6 @@
+pm-utils for Debian
+-------------------
+
+<possible notes regarding this package - if none, delete this file>
+
+ -- Victor Lowther <victor.lowther@gmail.com> Wed, 05 Mar 2008 23:51:41 -0600
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5957745
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,17 @@
+Source: pm-utils
+Section: admin
+Priority: optional
+Maintainer: Tim Dijkstra <tim@famdijkstra.org>
+Uploaders: Michael Biebl <biebl@debian.org>
+Build-Depends: debhelper (>= 5), docbook-utils, cdbs
+Standards-Version: 3.7.2
+
+Package: pm-utils
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, powermgmt-base
+Recommends: hal (>= 0.5.9), uswsusp, vbetool, radeontool
+Description: utilities and scripts for power management
+ This packages provides simple shell command line tools to suspend and
+ hibernate your computer.
+ .
+ Homepage: http://pm-utils.freedesktop.org/
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..7c75e19
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,40 @@
+This package was debianized by Victor Lowther <victor.lowther@gmail.com> on
+Wed, 05 Mar 2008 23:51:41 -0600.
+
+It was downloaded from <url://example.com>
+
+Upstream Author(s):
+
+ <put author's name and email here>
+ <likewise for another author>
+
+Copyright:
+
+ <Copyright (C) YYYY Name OfAuthor>
+ <likewise for another author>
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+The Debian packaging is (C) 2008, Victor Lowther <victor.lowther@gmail.com> and
+is licensed under the GPL, see above.
+
+
+# Please also look if there are files or directories which have a
+# different copyright/license attached and list them here.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..50bd824
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+NEWS
+README
diff --git a/debian/pm-utils.doc-base.EX b/debian/pm-utils.doc-base.EX
new file mode 100644
index 0000000..c93c821
--- /dev/null
+++ b/debian/pm-utils.doc-base.EX
@@ -0,0 +1,22 @@
+Document: pm-utils
+Title: Debian pm-utils Manual
+Author: <insert document author here>
+Abstract: This manual describes what pm-utils is
+ and how it can be used to
+ manage online manuals on Debian systems.
+Section: unknown
+
+Format: debiandoc-sgml
+Files: /usr/share/doc/pm-utils/pm-utils.sgml.gz
+
+Format: postscript
+Files: /usr/share/doc/pm-utils/pm-utils.ps.gz
+
+Format: text
+Files: /usr/share/doc/pm-utils/pm-utils.text.gz
+
+Format: HTML
+Index: /usr/share/doc/pm-utils/html/index.html
+Files: /usr/share/doc/pm-utils/html/*.html
+
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2e972fd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+
+binary-install/pm-utils::
+ # be nice, don't overwrite on_ac_power.
+ # It is provided in powermgmt-base
+ rm -f debian/pm-utils/usr/bin/on_ac_power
+ rm -f debian/pm-utils/usr/share/man/man1/on_ac_power.1