path: root/README
diff options
authorArch Librarian <>2005-07-14 13:05:59 +0000
committerArch Librarian <>2005-07-14 13:05:59 +0000
commitb1584b5aaf9ce396e61599caff2b5e15f01daf91 (patch)
treeffa1e807ffcb01ef8f5e3a7316fd0c2a808d8af2 /README
parent3ab7ea98e53d65aeae64de62511e1645b883584e (diff)
Improve pkg-config's configure instructure and bring it bang
Author: keybuk Date: 2004-06-07 23:43:21 GMT Improve pkg-config's configure instructure and bring it bang up to date. * pkg.m4: Complete rewrite. (PKG_PROG_PKG_CONFIG): if PKG_CONFIG not defined, find the pkg-config in the path or $host-pkg-config if cross-compiling, check that is of at least version 0.9.0 or one given. (_PKG_CONFIG): internal macro to call pkg-config. (PKG_CHECK_MODULES): same semantics as the previous incarnation except you can prevent pkg-config from being called by defining xxx_CFLAGS and xxx_LIBS yourself, additionally all results are cached. * README, pkg-config.1: Adjust documentation to match.
Diffstat (limited to 'README')
1 files changed, 11 insertions, 5 deletions
diff --git a/README b/README
index 6efa507..9c60ef6 100644
--- a/README
+++ b/README
@@ -6,20 +6,26 @@ gnome-specific but was a convenient bug tracker).
To use pkg-config, do something like the following in your
- PKG_CHECK_MODULES(GNOME, gtk > 1.2.8 gnomeui >= 1.2.0)
+ PKG_CHECK_MODULES([GNOME], [gtk > 1.2.8 gnomeui >= 1.2.0])
This puts the neccesary include flags to compile/link something against
libgnomeui and all its dependencies in $(GNOME_CFLAGS), and the -L/-l flags
-for linking in $(GNOME_LIBS)
+for linking in $(GNOME_LIBS).
+Users can define the PKG_CONFIG environment variable to point at the
+right one, or if they cross-compile and have a correctly named pkg-config
+(eg. arm-linux-pkg-config) in their PATH that will be used in preference.
+Users can also define the GNOME_CFLAGS and GNOME_LIBS environment variables
+if they think they know better, pkg-config will not be called if they do
The "gtk > 1.2.8" part is only neccesary if you want to specifically check
if libgtk is version 1.2.8 or higher. Otherwise, the flags for gtk
will be included automatically, since libgnomeui depends on gtk.
So you could just say:
for any version of gnomeui.