summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Hellström <thomas@shipmail.org>2006-03-17 19:27:17 +0000
committerThomas Hellström <thomas@shipmail.org>2006-03-17 19:27:17 +0000
commitfc5a69b231caec32e905328be0a5b4fc1fa275fe (patch)
tree5a00e220aadff2b5049295a8114d82d781b233f3 /configure.ac
parenta82a0745b5be0e9bb6b814ad4cd1e8c7abc0fa08 (diff)
- Update compatibility check for XvMC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cc4ba72658b2..5a9e516b52fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,14 @@ if test "$DRI" = yes; then
XVMC=no ;;
esac
fi
+
+if test "x$XVMC" = xyes; then
+ AC_CHECK_HEADERS(pthread.h sys/ioctl.h sys/time.h time.h,,[XVMC="no"; break],)
+fi
+
+AC_MSG_CHECKING([whether to build XvMC driver support])
+AC_MSG_RESULT([$XVMC])
+
AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
AC_SUBST([DRI_CFLAGS])