summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 5d8d554d711..c2566b7a687 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -82,7 +82,9 @@ if with_gallium
subdir('gallium')
# This has to be here since it requires libgallium, and subdir cannot
# contain ..
- subdir('mesa/state_tracker/tests')
+ if with_tests
+ subdir('mesa/state_tracker/tests')
+ endif
endif
# This must be after at least mesa, glx, and gallium, since libgl will be