summaryrefslogtreecommitdiff
path: root/src/mapi/shared-glapi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/mapi/shared-glapi/meson.build')
-rw-r--r--src/mapi/shared-glapi/meson.build23
1 files changed, 13 insertions, 10 deletions
diff --git a/src/mapi/shared-glapi/meson.build b/src/mapi/shared-glapi/meson.build
index 3776f9e30ab..2cb93d77883 100644
--- a/src/mapi/shared-glapi/meson.build
+++ b/src/mapi/shared-glapi/meson.build
@@ -18,13 +18,15 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
-files_mapi_glapi = files(
+files_shared_glapi = files(
'../entry.c',
- '../mapi_glapi.c',
- '../stub.c',
- '../stub.h',
- '../table.c',
- '../table.h',
+ '../u_current.c',
+ '../u_current.h',
+ 'glapi.c',
+ 'stub.c',
+ 'stub.h',
+ 'table.c',
+ 'table.h',
)
shared_glapi_mapi_tmp_h = custom_target(
@@ -43,7 +45,7 @@ endif
libglapi = shared_library(
'glapi',
- [files_mapi_glapi, files_mapi_util, shared_glapi_mapi_tmp_h],
+ [files_shared_glapi, shared_glapi_mapi_tmp_h],
c_args : [
_glapi_c_args,
c_msvc_compat_args,
@@ -54,10 +56,10 @@ libglapi = shared_library(
gnu_symbol_visibility : 'hidden',
link_args : [ld_args_gc_sections],
include_directories : [inc_src, inc_include, inc_mapi],
- dependencies : [dep_thread, dep_selinux],
+ dependencies : [dep_thread, dep_selinux, idep_mesautil],
soversion : host_machine.system() == 'windows' ? '' : '0',
version : '0.0.0',
- name_prefix : 'lib',
+ name_prefix : host_machine.system() == 'windows' ? 'lib' : [], # always use lib, but avoid warnings on !windows
install : true,
)
libglapi_build_dir = meson.current_build_dir()
@@ -71,9 +73,10 @@ if with_any_opengl and with_tests
cpp_args : [cpp_msvc_compat_args],
include_directories : [inc_src, inc_include, inc_mapi],
link_with : [libglapi],
- dependencies : [dep_thread, idep_gtest],
+ dependencies : [dep_thread, idep_gtest, idep_mesautilc11],
),
suite : ['mapi'],
+ protocol : 'gtest',
)
if with_symbols_check
test(