summaryrefslogtreecommitdiff
path: root/src/mapi/glapi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mapi/glapi/Makefile.am')
-rw-r--r--src/mapi/glapi/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/mapi/glapi/Makefile.am b/src/mapi/glapi/Makefile.am
index 05c67a6d4b8..bf653a30543 100644
--- a/src/mapi/glapi/Makefile.am
+++ b/src/mapi/glapi/Makefile.am
@@ -33,10 +33,11 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/mesa
if HAVE_X86_ASM
-GLAPI_ASM_SOURCES = $(X86_API)
-endif
if HAVE_X86_64_ASM
GLAPI_ASM_SOURCES = $(X86_64_API)
+else
+GLAPI_ASM_SOURCES = $(X86_API)
+endif
endif
if HAVE_SPARC_ASM
GLAPI_ASM_SOURCES = $(SPARC_API)