summaryrefslogtreecommitdiff
path: root/src/gallium/winsys/i915/drm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/winsys/i915/drm/Makefile.am')
-rw-r--r--src/gallium/winsys/i915/drm/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/gallium/winsys/i915/drm/Makefile.am b/src/gallium/winsys/i915/drm/Makefile.am
new file mode 100644
index 00000000000..b7b61454294
--- /dev/null
+++ b/src/gallium/winsys/i915/drm/Makefile.am
@@ -0,0 +1,38 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/gallium/drivers \
+ $(GALLIUM_CFLAGS) \
+ $(INTEL_CFLAGS)
+
+noinst_LTLIBRARIES = libi915drm.la
+
+libi915drm_la_SOURCES = $(C_SOURCES)
+
+#XXX: Delete this when all targets using the i915 winsys are converted to automake.
+all-local: libi915drm.la
+ ln -f $(builddir)/.libs/libi915drm.a $(builddir)/libi915drm.a