summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 34e2a032548..2d730708d06 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-# Copyright © 2017-2018 Intel Corporation
+# Copyright © 2017-2019 Intel Corporation
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -162,6 +162,14 @@ with_gallium_svga = _drivers.contains('svga')
with_gallium_virgl = _drivers.contains('virgl')
with_gallium_swr = _drivers.contains('swr')
+if cc.get_id() == 'intel'
+ if meson.version().verson_compare('< 0.49.0')
+ error('Meson does not have sufficient support of ICC before 0.49.0 to compile mesa')
+ elif with_gallium_swr and meson.version().verson_compare('== 0.49.0')
+ warning('Meson as of 0.49.0 is sufficient for compiling mesa with ICC, but there are some caveats with SWR. 0.49.1 should resolve all of these')
+ endif
+endif
+
with_gallium = _drivers.length() != 0 and _drivers != ['']
if with_gallium and system_has_kms_drm