summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build48
1 files changed, 2 insertions, 46 deletions
diff --git a/meson.build b/meson.build
index a6b0db1aad7..7247c32b9ac 100644
--- a/meson.build
+++ b/meson.build
@@ -83,7 +83,6 @@ if with_tools.contains('all')
'lima',
'nir',
'nouveau',
- 'xvmc',
'asahi',
'imagination',
]
@@ -695,47 +694,7 @@ if with_vulkan_overlay_layer or with_aco_tests or with_amd_vk
endif
endif
-_xvmc = get_option('gallium-xvmc')
-if _xvmc == 'true'
- _xvmc = 'enabled'
- warning('gallium-xvmc option "true" deprecated, please use "enabled" instead.')
-elif _xvmc == 'false'
- _xvmc = 'disabled'
- warning('gallium-xvmc option "false" deprecated, please use "disabled" instead.')
-endif
-if not system_has_kms_drm
- if _xvmc == 'enabled'
- error('XVMC state tracker can only be build on unix-like OSes.')
- else
- _xvmc = 'disabled'
- endif
-elif not with_platform_x11
- if _xvmc == 'enabled'
- error('XVMC state tracker requires X11 support.')
- else
- _xvmc = 'disabled'
- endif
-elif not (with_gallium_r600 or with_gallium_nouveau)
- if _xvmc == 'enabled'
- error('XVMC state tracker requires at least one of the following gallium drivers: r600, nouveau.')
- else
- _xvmc = 'disabled'
- endif
-endif
-dep_xvmc = null_dep
dep_xv = null_dep
-with_gallium_xvmc = false
-if _xvmc != 'disabled'
- dep_xvmc = dependency('xvmc', version : '>= 1.0.6', required : _xvmc == 'enabled')
- dep_xv = dependency('xv', required : _xvmc == 'enabled')
- with_gallium_xvmc = dep_xvmc.found() and dep_xv.found()
-endif
-
-xvmc_drivers_path = get_option('xvmc-libs-path')
-if xvmc_drivers_path == ''
- xvmc_drivers_path = get_option('libdir')
-endif
-
_omx = get_option('gallium-omx')
if not system_has_kms_drm
if ['auto', 'disabled'].contains(_omx)
@@ -2152,7 +2111,7 @@ if with_platform_x11
dep_xcb_shm = dependency('xcb-shm')
endif
if (with_any_vk or with_glx == 'dri' or with_egl or
- (with_gallium_vdpau or with_gallium_xvmc or with_gallium_va or
+ (with_gallium_vdpau or with_gallium_va or
with_gallium_omx != 'disabled'))
dep_xcb = dependency('xcb')
dep_x11_xcb = dependency('x11-xcb')
@@ -2189,7 +2148,7 @@ if with_platform_x11
endif
if (with_egl or
with_dri3 or (
- with_gallium_vdpau or with_gallium_xvmc or with_gallium_xa or
+ with_gallium_vdpau or with_gallium_xa or
with_gallium_omx != 'disabled'))
dep_xcb_xfixes = dependency('xcb-xfixes')
endif
@@ -2408,9 +2367,6 @@ if with_gallium
if with_gallium_xa
gallium_st += 'xa'
endif
- if with_gallium_xvmc
- gallium_st += 'xvmc'
- endif
if with_gallium_vdpau
gallium_st += 'vdpau'
endif