summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
2 files changed, 10 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 6c395f48ef8..2e6676fac6c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mesa (6.5.1-0.4) unstable; urgency=medium
+
+ * Non-maintainer upload (and brown paper bag release).
+ * _Depend_ on libx11-dev from libgl1-mesa-dev; revert previous change.
+ Fixes FTBFS in other packages. (Really Closes: #396498)
+
+ -- Steinar H. Gunderson <sesse@debian.org> Sat, 11 Nov 2006 13:55:20 +0100
+
mesa (6.5.1-0.3) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/control b/debian/control
index 83a905689b8..8217fb89cb4 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Mesa package maintainers <pkg-mesa-devel@lists.alioth.debian.org>
Uploaders: Marcelo E. Magallon <mmagallo@debian.org>
Standards-Version: 3.7.2
-Build-Depends: lesstif2-dev, grep-dctrl, debhelper (>> 4), build-essential (>= 11), libdrm-dev (>= 2.0.2) [!hurd-i386], libdirectfb-dev [!hurd-i386], xutils, libexpat-dev, libxxf86vm-dev, libx11-dev, libxext-dev, pkg-config, x11proto-gl-dev (>= 1.4.8) , dpkg-dev (>= 1.13.19), libx11-dev
+Build-Depends: lesstif2-dev, grep-dctrl, debhelper (>> 4), build-essential (>= 11), libdrm-dev (>= 2.0.2) [!hurd-i386], libdirectfb-dev [!hurd-i386], xutils, libexpat-dev, libxxf86vm-dev, libx11-dev, libxext-dev, pkg-config, x11proto-gl-dev (>= 1.4.8) , dpkg-dev (>= 1.13.19)
Package: libgl1-mesa-swx11
Section: libs
@@ -99,7 +99,7 @@ Description: A free implementation of the OpenGL API -- DRI modules
Package: libgl1-mesa-dev
Section: libs
Architecture: any
-Depends: ${shlibs:Depends}, libc6-dev, mesa-common-dev (= ${source:Version}), libgl1-mesa-glx (=${binary:Version}), libgl1-mesa-dri (= ${binary:Version})
+Depends: ${shlibs:Depends}, libx11-dev, libc6-dev, mesa-common-dev (= ${source:Version}), libgl1-mesa-glx (=${binary:Version}), libgl1-mesa-dri (= ${binary:Version})
Conflicts: libgl-dev, libgl1-mesa-dri-dev
Replaces: libgl-dev, libgl1-mesa-dri-dev
Provides: libgl-dev, libgl1-mesa-dri-dev