summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ba922580e84..70c598e0882 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1319,9 +1319,15 @@ dnl Gallium G3DVL configuration
dnl
AC_ARG_ENABLE([gallium-g3dvl],
[AS_HELP_STRING([--disable-gallium-g3dvl],
- [build gallium g3dvl @<:@default=enabled@:>@])],
+ [build gallium g3dvl @<:@default=auto@:>@])],
[enable_gallium_g3dvl="$enableval"],
- [enable_gallium_g3dvl=yes])
+ [enable_gallium_g3dvl=auto])
+if test "x$enable_gallium_g3dvl" = xauto; then
+ if test "x$with_gallium_drivers" != x; then
+ enable_gallium_g3dvl=yes
+ fi
+fi
+
if test "x$enable_gallium_g3dvl" = xyes; then
if test "x$with_gallium_drivers" = x; then
AC_MSG_ERROR([cannot enable G3DVL without Gallium])