summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--SConstruct6
-rw-r--r--src/gallium/drivers/sw/SConscript8
-rw-r--r--src/gallium/state_trackers/python/SConscript4
-rw-r--r--src/gallium/targets/dri-swrast/SConscript8
-rw-r--r--src/gallium/targets/graw-xlib/SConscript8
-rw-r--r--src/gallium/targets/libgl-gdi/SConscript8
-rw-r--r--src/gallium/targets/libgl-xlib/SConscript8
7 files changed, 17 insertions, 33 deletions
diff --git a/SConstruct b/SConstruct
index ebced16c0ce..fdcd72b30d1 100644
--- a/SConstruct
+++ b/SConstruct
@@ -102,11 +102,15 @@ Export([
#######################################################################
# Environment setup
-# Always build trace and identity drivers
+# Always build trace, identity, softpipe, and llvmpipe (where possible)
if 'trace' not in env['drivers']:
env['drivers'].append('trace')
if 'identity' not in env['drivers']:
env['drivers'].append('identity')
+if 'softpipe' not in env['drivers']:
+ env['drivers'].append('softpipe')
+if env['llvm'] and 'llvmpipe' not in env['drivers']:
+ env['drivers'].append('llvmpipe')
# Includes
env.Append(CPPPATH = [
diff --git a/src/gallium/drivers/sw/SConscript b/src/gallium/drivers/sw/SConscript
index cea237aa171..37d0a0d63ce 100644
--- a/src/gallium/drivers/sw/SConscript
+++ b/src/gallium/drivers/sw/SConscript
@@ -12,17 +12,13 @@
Import('*')
-if not set(('softpipe', 'llvmpipe', 'cell')).intersection(env['drivers']):
- print 'warning: no supported pipe driver: skipping build of sw meta-driver'
- Return()
-
env = env.Clone()
-if 'softpipe' in env['drivers']:
+if True:
env.Append(CPPDEFINES = 'GALLIUM_SOFTPIPE')
env.Prepend(LIBS = [softpipe])
-if 'llvmpipe' in env['drivers']:
+if env['llvm']:
env.Append(CPPDEFINES = 'GALLIUM_LLVMPIPE')
env.Tool('udis86')
env.Prepend(LIBS = [llvmpipe])
diff --git a/src/gallium/state_trackers/python/SConscript b/src/gallium/state_trackers/python/SConscript
index bff97079f6b..aadeaa0a359 100644
--- a/src/gallium/state_trackers/python/SConscript
+++ b/src/gallium/state_trackers/python/SConscript
@@ -44,10 +44,10 @@ if 'python' in env['statetrackers']:
gallium,
])
- if 'llvmpipe' in env['drivers']:
+ if env['llvm']:
env.Append(CPPDEFINES = ['HAVE_LLVMPIPE'])
env.Prepend(LIBS = [llvmpipe])
- if 'softpipe' in env['drivers']:
+ if True:
env.Append(CPPDEFINES = ['HAVE_SOFTPIPE'])
env.Prepend(LIBS = [softpipe])
diff --git a/src/gallium/targets/dri-swrast/SConscript b/src/gallium/targets/dri-swrast/SConscript
index 9a3838d64e2..77f44384d06 100644
--- a/src/gallium/targets/dri-swrast/SConscript
+++ b/src/gallium/targets/dri-swrast/SConscript
@@ -1,9 +1,5 @@
Import('*')
-if not set(('softpipe', 'llvmpipe')).intersection(env['drivers']):
- print 'warning: no supported pipe driver: skipping build of swrastg_dri.so'
- Return()
-
env = drienv.Clone()
env.Append(CPPPATH = [
@@ -20,11 +16,11 @@ env.Prepend(LIBS = [
COMMON_DRI_SW_OBJECTS
])
-if 'softpipe' in env['drivers']:
+if True:
env.Append(CPPDEFINES = 'GALLIUM_SOFTPIPE')
env.Prepend(LIBS = [softpipe])
-if 'llvmpipe' in env['drivers']:
+if env['llvm']:
env.Append(CPPDEFINES = 'GALLIUM_LLVMPIPE')
env.Tool('udis86')
env.Prepend(LIBS = [llvmpipe])
diff --git a/src/gallium/targets/graw-xlib/SConscript b/src/gallium/targets/graw-xlib/SConscript
index 1b5350a9a48..979252b22d7 100644
--- a/src/gallium/targets/graw-xlib/SConscript
+++ b/src/gallium/targets/graw-xlib/SConscript
@@ -6,10 +6,6 @@ Import('*')
if env['platform'] != 'linux':
Return()
-if not set(('softpipe', 'llvmpipe', 'cell')).intersection(env['drivers']):
- print 'warning: no supported pipe driver: skipping build of xlib libGL.so'
- Return()
-
env = env.Clone()
env.Prepend(LIBS = [
@@ -28,11 +24,11 @@ sources = [
'graw_xlib.c',
]
-if 'softpipe' in env['drivers']:
+if True:
env.Append(CPPDEFINES = 'GALLIUM_SOFTPIPE')
env.Prepend(LIBS = [softpipe])
-if 'llvmpipe' in env['drivers']:
+if env['llvm']:
env.Append(CPPDEFINES = 'GALLIUM_LLVMPIPE')
env.Tool('udis86')
env.Prepend(LIBS = [llvmpipe])
diff --git a/src/gallium/targets/libgl-gdi/SConscript b/src/gallium/targets/libgl-gdi/SConscript
index a6ef1f2406a..2a55c7a5776 100644
--- a/src/gallium/targets/libgl-gdi/SConscript
+++ b/src/gallium/targets/libgl-gdi/SConscript
@@ -22,18 +22,14 @@ if env['platform'] == 'windows':
sources = []
drivers = []
- if 'softpipe' in env['drivers']:
+ if True:
sources = ['gdi_softpipe_winsys.c']
drivers = [softpipe]
- if 'llvmpipe' in env['drivers']:
+ if env['llvm']:
sources = ['gdi_llvmpipe_winsys.c']
drivers = [llvmpipe]
- if not sources or not drivers:
- print 'warning: softpipe or llvmpipe not selected, gdi winsys disabled'
- Return()
-
if env['gcc']:
sources += ['#src/gallium/state_trackers/wgl/opengl32.mingw.def']
else:
diff --git a/src/gallium/targets/libgl-xlib/SConscript b/src/gallium/targets/libgl-xlib/SConscript
index 0d2ffd20709..63e4531263a 100644
--- a/src/gallium/targets/libgl-xlib/SConscript
+++ b/src/gallium/targets/libgl-xlib/SConscript
@@ -14,10 +14,6 @@ if env['dri']:
print 'warning: DRI enabled: skipping build of xlib libGL.so'
Return()
-if not set(('softpipe', 'llvmpipe', 'cell')).intersection(env['drivers']):
- print 'warning: no supported pipe driver: skipping build of xlib libGL.so'
- Return()
-
env = env.Clone()
env.Append(CPPPATH = [
@@ -45,11 +41,11 @@ sources = [
env.Tool('x11')
-if 'softpipe' in env['drivers']:
+if True:
env.Append(CPPDEFINES = 'GALLIUM_SOFTPIPE')
env.Prepend(LIBS = [softpipe])
-if 'llvmpipe' in env['drivers']:
+if env['llvm']:
env.Append(CPPDEFINES = 'GALLIUM_LLVMPIPE')
env.Tool('udis86')
env.Prepend(LIBS = [llvmpipe])