summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-02-08 13:10:12 -0800
committerDylan Baker <dylan@pnwbakers.com>2019-09-10 20:36:47 +0000
commitf680cc62f85e66feed2fe0794f415534d3a4df98 (patch)
treefc2eee16664916bf9fbbe1498ac5f33c5d426074 /src/meson.build
parent0caa229dcb52d0da14bb45b29781fb781e723d68 (diff)
meson: build getopt when using msvc
v4: - Don't wrap a single file in a list to match mesa style - Use null_dep instead of empty list Reviewed-by: Eric Anholt <eric@anholt.net> (v3) Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index d86c0ec21a6..71ff82af38f 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -47,6 +47,11 @@ sha1_h = custom_target(
)
subdir('gtest')
+if cc.get_id() == 'msvc'
+ subdir('getopt')
+else
+ idep_getopt = null_dep
+endif
subdir('util')
subdir('mapi')
# TODO: opengl