summaryrefslogtreecommitdiff
path: root/src/intel/tools/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-09-14 17:57:17 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-09-27 09:12:19 -0700
commitd1992255bb29054fa51763376d125183a9f602f3 (patch)
tree4a132f8e640661d4933c6ddb010185c870ef99d0 /src/intel/tools/meson.build
parentc8b9cf429f9b2ce1cd17759eecbdbb0482ab271c (diff)
meson: Add build Intel "anv" vulkan driver
This allows building and installing the Intel "anv" Vulkan driver using meson and ninja, the driver has been tested against the CTS and has seems to pass the same series of tests (they both segfault when the CTS tries to run wayland wsi tests). There are still a mess of TODO, XXX, and FIXME comments in here. Those are mostly for meson bugs I'm trying to fix, or for additional things to implement for other drivers/features. I have configured all intermediate libraries and optional tools to not build by default, meaning they will only be built if they're pulled in as a dependency of a target that will actually be installed) this allows us to avoid massive if chains, while ensuring that only the bits that need to be built are. v2: - enable anv, x11, and wayland by default - add configure option to disable valgrind v3: - fix typo in meson_options (Nicholas) v4: - Remove dead code (Eric) - Remove change to generator that was from v0 (Eric) - replace if chain with loop (Eric) - Fix typos (Eric) - define HAVE_DLOPEN for both libdl and builtin dl cases (Eric) v5: - rebase on util string buffer implementation Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net> (v4)
Diffstat (limited to 'src/intel/tools/meson.build')
-rw-r--r--src/intel/tools/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/intel/tools/meson.build b/src/intel/tools/meson.build
new file mode 100644
index 00000000000..91092fdb512
--- /dev/null
+++ b/src/intel/tools/meson.build
@@ -0,0 +1,39 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+aubinator = executable(
+ 'aubinator',
+ files('aubinator.c', 'disasm.c', 'gen_disasm.h', 'intel_aub.h'),
+ dependencies : [dep_expat, dep_zlib, dep_dl, dep_thread, dep_m],
+ include_directories : [inc_common, inc_intel],
+ link_with : [libintel_common, libintel_compiler, libmesa_util],
+ c_args : [c_vis_args, no_override_init_args],
+ build_by_default : false,
+)
+
+aubinator_error_decode = executable(
+ 'aubinator_error_decode',
+ files('aubinator_error_decode.c', 'disasm.c', 'gen_disasm.h'),
+ dependencies : [dep_expat, dep_zlib, dep_thread],
+ include_directories : [inc_common, inc_intel],
+ link_with : [libintel_common, libintel_compiler, libmesa_util],
+ c_args : [c_vis_args, no_override_init_args],
+ build_by_default : false,
+)