summaryrefslogtreecommitdiff
path: root/src/glsl/tests/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <kenneth@whitecape.org>2012-05-29 11:16:34 -0700
committerKenneth Graunke <kenneth@whitecape.org>2012-05-30 21:49:41 -0700
commit151bf6e6cf8f9de4067cfcf15f6ac448ff295533 (patch)
tree6c69345a5fed54f780a2b5e4b8b5ba063b5c5cb3 /src/glsl/tests/Makefile.am
parenta44ccdc8760fdbd5ba5c01ffff3809fbfb364934 (diff)
glsl/tests: Plumb $(PYTHON2) and $(PYTHON_FLAGS) into optimization-test.
Some distributions (like Arch Linux) make /usr/bin/python Python 3, rather than Python 2. Since compare_ir uses /usr/bin/env python, such systems will fail to run optimization-test, causing 'make check' to always fail. Automake's TESTS_ENVIRONMENT variable provides a mechanism to run programs or set environment variables in the test environment. Ideally, I think we would want to use AM_TESTS_ENVIRONMENT, since TESTS_ENVIRONMENT is supposed to be user-overridable. However, it isn't supported using the default/serial test runner. Fixes 'make check' on Arch Linux and Gentoo. Signed-off-by: Kenneth Graunke <kenneth@whitecape.org> Acked-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/glsl/tests/Makefile.am')
-rw-r--r--src/glsl/tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/glsl/tests/Makefile.am b/src/glsl/tests/Makefile.am
index c1c74e75b57..d2facbaabb8 100644
--- a/src/glsl/tests/Makefile.am
+++ b/src/glsl/tests/Makefile.am
@@ -7,6 +7,10 @@ INC = \
AM_CFLAGS = $(INC)
AM_CXXFLAGS = $(INC)
+TESTS_ENVIRONMENT= \
+ export PYTHON2=$(PYTHON2); \
+ export PYTHON_FLAGS=$(PYTHON_FLAGS);
+
TESTS = \
optimization-test \
ralloc-test \