summaryrefslogtreecommitdiff
path: root/src/gallium/winsys/svga/drm/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-26 15:32:09 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-11-01 15:05:26 -0700
commit6594213cfa332be88551596bf56cf01538339f37 (patch)
tree3d273663c334fa3d715cd8964b73dcfdf46696cc /src/gallium/winsys/svga/drm/Makefile.am
parent1f2640bfa940362c7550cdd065d37555f21c8ae8 (diff)
svga: Use __asm__ instead of asm
__asm__ is portable, and allows the svga driver to be compiled with the c99 standard instead of requiring the gnu99 standard. I have compile tested this with GCC and Clang on Linux. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Brian Paul <brianp@vmware.com> Tested-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'src/gallium/winsys/svga/drm/Makefile.am')
-rw-r--r--src/gallium/winsys/svga/drm/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/gallium/winsys/svga/drm/Makefile.am b/src/gallium/winsys/svga/drm/Makefile.am
index dfa97367650..ac9de18d3df 100644
--- a/src/gallium/winsys/svga/drm/Makefile.am
+++ b/src/gallium/winsys/svga/drm/Makefile.am
@@ -29,9 +29,6 @@ AM_CFLAGS = \
$(GALLIUM_WINSYS_CFLAGS) \
$(LIBDRM_CFLAGS)
-#On some systems -std= must be added to CFLAGS to be the last -std=
-CFLAGS += -std=gnu99
-
noinst_LTLIBRARIES = libsvgadrm.la
libsvgadrm_la_SOURCES = $(C_SOURCES)