summaryrefslogtreecommitdiff
path: root/src/gallium/targets/vdpau/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2020-04-24 13:10:41 -0700
committerMarge Bot <eric+marge@anholt.net>2020-06-01 18:59:18 +0000
commita8e2d79e0228106d11b6ceeb38f4ffb587f0a819 (patch)
tree18eef778716e07f993f568e54920e2242fd0b717 /src/gallium/targets/vdpau/meson.build
parentfc7301865e1eabe06d4225af596e7334c4094fe5 (diff)
meson: use gnu_symbol_visibility argument
This uses a meson builtin to handle -fvisibility=hidden. This is nice because we don't need to track which languages are used, if C++ is suddenly added meson just does the right thing. Acked-by: Matt Turner <mattst88@gmail.com> Reviewed-by: Eric Engestrom <eric@engestrom.ch> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4740>
Diffstat (limited to 'src/gallium/targets/vdpau/meson.build')
-rw-r--r--src/gallium/targets/vdpau/meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/gallium/targets/vdpau/meson.build b/src/gallium/targets/vdpau/meson.build
index 4ea12c4ef02..82c6b6d2287 100644
--- a/src/gallium/targets/vdpau/meson.build
+++ b/src/gallium/targets/vdpau/meson.build
@@ -39,8 +39,7 @@ endif
libvdpau_gallium = shared_library(
'vdpau_gallium',
'target.c',
- c_args : c_vis_args,
- cpp_args : cpp_vis_args,
+ gnu_symbol_visibility : 'hidden',
link_args : [vdpau_link_args, ld_args_gc_sections],
include_directories : [
inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux, inc_util, inc_gallium_winsys, inc_gallium_drivers,