summaryrefslogtreecommitdiff
path: root/src/gallium/targets/dri-swrast/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2013-10-29 21:14:41 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2013-10-29 21:14:41 +0000
commitaec20d66d9d13e0acd6a7199b63e1383e1e9900a (patch)
tree9c5a643bb50df3ffdfa7e90a2bc55c49f0d2420f /src/gallium/targets/dri-swrast/Makefile.am
parent0828ad4e63df512c9d21e6e75b32f03401c3e95a (diff)
automake: properly handle non-default expat installation
Use PKG_CHECK_MODULE over requesting the user to setup the option at configure time. Drop unused EXPAT_INCLUDE and update all targets. NOTE: The this commit removes the --with-expat configure option. One should ensure that the expat they wish to use has expat.pc file accessible by pkg-config. v2: * Add note about the removal of --with-expat (per Tom Stellard) * Drop EXPAT_CFLAGS for targets that do not build DRI_COMMON (spotted by Matt Turner) v3: * Rebase on top of megadrivers (drop EXPAT_CFLAGS from swrast) Acked-by: Matt Turner <mattst88@gmail.com> (v2) Reviewed-by: Tom Stellard <thomas.stellard@amd.com> (v2) Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Conflicts: configure.ac src/mesa/drivers/dri/common/Makefile.am
Diffstat (limited to 'src/gallium/targets/dri-swrast/Makefile.am')
-rw-r--r--src/gallium/targets/dri-swrast/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/targets/dri-swrast/Makefile.am b/src/gallium/targets/dri-swrast/Makefile.am
index 6b629df307d..cddbbe32bb4 100644
--- a/src/gallium/targets/dri-swrast/Makefile.am
+++ b/src/gallium/targets/dri-swrast/Makefile.am
@@ -25,6 +25,7 @@ include $(top_srcdir)/src/gallium/Automake.inc
AM_CFLAGS = \
$(GALLIUM_CFLAGS) \
$(PTHREAD_CFLAGS) \
+ $(EXPAT_CFLAGS) \
$(LIBDRM_CFLAGS) \
$(VISIBILITY_CFLAGS)
AM_CPPFLAGS = \